import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^[A-Za-z]|(?<=[^\\w])[A-Za-z]|(?<![A-Z])[A-Z])";
final String string = "PHP: Hypertext Preprocessor\n"
+ "Portable Network Graphics\n"
+ "Ruby on Rails\n"
+ "HyperText Markup Language\n"
+ "First In, First Out\n"
+ "Complementary metal-oxide semiconductor";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}