import re
regex = re.compile(r"(^[A-Za-z]|(?<=[^\w])[A-Za-z]|(?<![A-Z])[A-Z])")
test_str = ("PHP: Hypertext Preprocessor\n"
"Portable Network Graphics\n"
"Ruby on Rails\n"
"HyperText Markup Language\n"
"First In, First Out\n"
"Complementary metal-oxide semiconductor")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")