re = /(^[A-Za-z]|(?<=[^\w])[A-Za-z]|(?<![A-Z])[A-Z])/
str = 'PHP: Hypertext Preprocessor
Portable Network Graphics
Ruby on Rails
HyperText Markup Language
First In, First Out
Complementary metal-oxide semiconductor'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end