package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[0-9]*:[0-5][0-9][pm PM am AM]*$`)
var str = `12:45pm
9:59 AM
6:60am
five o'clock`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}