$re = '/[0-9]*:[0-5][0-9][pm PM am AM]*$/m';
$str = '12:45pm
9:59 AM
6:60am
five o\'clock';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);