re = /[0-9]*:[0-5][0-9][pm PM am AM]*$/m
str = '12:45pm
9:59 AM
6:60am
five o\'clock'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end