const regex = /(,[^.?]*)( and|or)\b/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(,[^.?]*)( and|or)\\b', 'gim')
const str = `I love my parents, Bon Jovi and Lada Gaga.
We invited the strippers, Hitler and Stalin.
The problem is, you can never know if the user is making a list, or just typing a bunch of words and inserting commas.`;
const subst = `$1,$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);