import re
regex = re.compile(r"(,[^.?]*)( and|or)\b", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("I love my parents, Bon Jovi and Lada Gaga.\n\n"
"We invited the strippers, Hitler and Stalin.\n\n"
"The problem is, you can never know if the user is making a list, or just typing a bunch of words and inserting commas.")
subst = "$1,$2"
result = regex.sub(subst, test_str)
if result:
print(result)