import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(,[^.?!\\n]*)( and| or)\\b";
final String string = "I love my parents, Bon Jovi and Lada Gaga.\n\n"
+ "We invited the strippers, Hitler and Stalin.\n\n"
+ "The problem is, you can never know if the user is making a list, or just typing a bunch of words and inserting commas.\n\n"
+ "I'm not sure whether to eat, shoot or leave!\n\n"
+ "Don't get this one or I'll be upset at you.\n\n"
+ "Put a command before this and I'll be sad.";
final String subst = "$1,$2";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}