use strict;
my $str = 'I love my parents, Bon Jovi and Lada Gaga.
We invited the strippers, Hitler and Stalin.
The problem is, you can never know if the user is making a list, or just typing a bunch of words and inserting commas.
I\'m not sure whether to eat, shoot or leave!
Don\'t get this one or I\'ll be upset at you.
Put a command before this and I\'ll be sad.';
my $regex = qr/(,[^.?!\n]*)( and| or)\b/ip;
my $subst = '$1,$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";