const regex = /(,[^.?!\n]*)( and| or)\b/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(,[^.?!\\n]*)( and| or)\\b', 'gi')
const str = `I love my parents, Bon Jovi and Lada Gaga.
We invited the strippers, Hitler and Stalin.
The problem is, you can never know if the user is making a list, or just typing a bunch of words and inserting commas.
I'm not sure whether to eat, shoot or leave!
Don't get this one or I'll be upset at you.
Put a command before this and I'll be sad.`;
const subst = `$1,$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);