using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^\p{Latin}\d \$\,\.\(\)\?\!\%\#\@\xA2]*";
string input = @"AB cµÀ´'(-+=0123¢-1-""";
RegexOptions options = RegexOptions.CultureInvariant;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}