package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^\p{Latin}\d \$\,\.\(\)\?\!\%\#\@\xA2]*`)
var str = `AB cµÀ´'(-+=0123¢-1-"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}