using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"@""^(100(\.00?)?)|([0-9]?[0-9](\.\d{1,2})?)$""";
string input = @"100";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}