const regex = new RegExp('@"^(100(\\.00?)?)|([0-9]?[0-9](\\.\\d{1,2})?)$"', '')
const str = `100`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}