$re = '/@"^(100(\.00?)?)|([0-9]?[0-9](\.\d{1,2})?)$"/';
$str = '100';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);