using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:^(?:(?!#summertime).)*$|^.*?#summertime)(*SKIP)(*F)|\w+";
string input = @"foo bar
#summertime swimming, running, tanning
swimming, running, tanning";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}