re = /(?:^(?:(?!#summertime).)*$|^.*?#summertime)(*SKIP)(*F)|\w+/m
str = 'foo bar
#summertime swimming, running, tanning
swimming, running, tanning'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end