$re = '/(?:^(?:(?!#summertime).)*$|^.*?#summertime)(*SKIP)(*F)|\w+/m';
$str = 'foo bar
#summertime swimming, running, tanning
swimming, running, tanning';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);