import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"(?'tsy_lib'.*?)\";(?:.*?;){4}\"(?'num_externe'.*?)\";(?:.*?;){2}\"(?'apt_nom'.*?)\";\"(?'apt_telephone'.*?)\";(?:.*?;){3}\"(?'apt_localisation'.*?)\";(?:.*?;)\"(?'ins_libl'.*?)\";(?:.*?;){5}\"(?'apt_e_mail'.*?)\";(?:.*?;){2}\"(?'commentaire_externe'.+)\"";
final String string = "\"I01.00.00\";\"005291\";\"CG45\";\"15085\";\"cnt_ext\";\"1905151405\";181349;\"CE_11\";\"DYER Isabelle\";\"02 38 25 40 72\";003;\"Non\";\"site_ext\";\"COLLEGE VAL DE LOIRE\";\"SIT_036\";\"COLLEGE VAL DE LOIRE\";\"[Dem : 1905151405] DYSFONCTIONNEMENT PORTE EXTERIEURE PRES DE LA SALLE\";\"28/05/2019 00:00\";\"CASTELLI Olivier\";\"02 38 49 20 00\";\"\";\"olivier.castelli1@ac-orleans-tours.fr\";\"28/05/2019 00:00\";0;\"r�soudre le dysfonctionnement de la porte ext�rieure � proximit� de la salle polyvalente. K151405\"\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}