const regex = /"(?'tsy_lib'.*?)";(?:.*?;){4}"(?'num_externe'.*?)";(?:.*?;){2}"(?'apt_nom'.*?)";"(?'apt_telephone'.*?)";(?:.*?;){3}"(?'apt_localisation'.*?)";(?:.*?;)"(?'ins_libl'.*?)";(?:.*?;){5}"(?'apt_e_mail'.*?)";(?:.*?;){2}"(?'commentaire_externe'.+)"/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"(?\'tsy_lib\'.*?)";(?:.*?;){4}"(?\'num_externe\'.*?)";(?:.*?;){2}"(?\'apt_nom\'.*?)";"(?\'apt_telephone\'.*?)";(?:.*?;){3}"(?\'apt_localisation\'.*?)";(?:.*?;)"(?\'ins_libl\'.*?)";(?:.*?;){5}"(?\'apt_e_mail\'.*?)";(?:.*?;){2}"(?\'commentaire_externe\'.+)"', 'gm')
const str = `"I01.00.00";"005291";"CG45";"15085";"cnt_ext";"1905151405";181349;"CE_11";"DYER Isabelle";"02 38 25 40 72";003;"Non";"site_ext";"COLLEGE VAL DE LOIRE";"SIT_036";"COLLEGE VAL DE LOIRE";"[Dem : 1905151405] DYSFONCTIONNEMENT PORTE EXTERIEURE PRES DE LA SALLE";"28/05/2019 00:00";"CASTELLI Olivier";"02 38 49 20 00";"";"olivier.castelli1@ac-orleans-tours.fr";"28/05/2019 00:00";0;"r�soudre le dysfonctionnement de la porte ext�rieure � proximit� de la salle polyvalente. K151405"
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}