// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)"(?'tsy_lib'.*?)";(?:.*?;){4}"(?'num_externe'.*?)";(?:.*?;){2}"(?'apt_nom'.*?)";"(?'apt_telephone'.*?)";(?:.*?;){3}"(?'apt_localisation'.*?)";(?:.*?;)"(?'ins_libl'.*?)";(?:.*?;){5}"(?'apt_e_mail'.*?)";(?:.*?;){2}"(?'commentaire_externe'.+)""#).unwrap();
let string = "\"I01.00.00\";\"005291\";\"CG45\";\"15085\";\"cnt_ext\";\"1905151405\";181349;\"CE_11\";\"DYER Isabelle\";\"02 38 25 40 72\";003;\"Non\";\"site_ext\";\"COLLEGE VAL DE LOIRE\";\"SIT_036\";\"COLLEGE VAL DE LOIRE\";\"[Dem : 1905151405] DYSFONCTIONNEMENT PORTE EXTERIEURE PRES DE LA SALLE\";\"28/05/2019 00:00\";\"CASTELLI Olivier\";\"02 38 49 20 00\";\"\";\"olivier.castelli1@ac-orleans-tours.fr\";\"28/05/2019 00:00\";0;\"r�soudre le dysfonctionnement de la porte ext�rieure � proximit� de la salle polyvalente. K151405\"
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}