# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\*\*(.+?)\*\*(?!\*)/<b>$1<\/b>/gm;t' <<< "some normal and **bold with * gem*** but pure *italics* is
***foo**bar***
**bold***
**a** **b**
***a* *b***"