#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\*\*(.+?)\*\*(?!\*)"
Local $sString = "some normal and **bold with * gem*** but pure *italics* is" & @CRLF & _
"***foo**bar***" & @CRLF & _
"**bold***" & @CRLF & _
"**a** **b**" & @CRLF & _
"***a* *b***"
Local $sSubst = "<b>$1</b>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)