const regex = /\*\*(.+?)\*\*(?!\*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\*\\*(.+?)\\*\\*(?!\\*)', 'gm')
const str = `some normal and **bold with * gem*** but pure *italics* is
***foo**bar***
**bold***
**a** **b**
***a* *b***`;
const subst = `<b>$1</b>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);