using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<div\sclass=""portal""(.*?)<\/div>";
string input = @"<div class=""portal"" role=""navigation"" id='p-participation' aria-labelledby='p-participation-label'>
<h3 id='p-participation-label'>Раз раз раз</h3>
</div> <div class=""portal"" role=""navigation"" id='p-tb' aria-labelledby='p-tb-label'>
<h3 id='p-tb-label'>Инструменты</h3>
</div> <div class=""portal"" role=""navigation"" id='p-coll-print_export' aria-labelledby='p-coll-print_export-label'>
<h3 id='p-coll-print_export-label'>Печать/экспорт</h3>
</div> <div class=""portal"" role=""navigation"" id='p-wikibase-otherprojects' aria-labelledby='p-wikibase-otherprojects-label'>
<h3 id='p-wikibase-otherprojects-label'>В других других</h3>
</div> <div class=""portal"" role=""navigation"" id='p-lang' aria-labelledby='p-lang-label'>
<h3 id='p-lang-label'>Три три три</h3>
</div>
";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}