import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<div\\sclass=\"portal\"(.*?)<\\/div>";
final String string = "<div class=\"portal\" role=\"navigation\" id='p-participation' aria-labelledby='p-participation-label'>\n"
+ " <h3 id='p-participation-label'>Раз раз раз</h3>\n\n"
+ " </div> <div class=\"portal\" role=\"navigation\" id='p-tb' aria-labelledby='p-tb-label'>\n"
+ " <h3 id='p-tb-label'>Инструменты</h3>\n\n"
+ " </div> <div class=\"portal\" role=\"navigation\" id='p-coll-print_export' aria-labelledby='p-coll-print_export-label'>\n"
+ " <h3 id='p-coll-print_export-label'>Печать/экспорт</h3>\n\n"
+ " </div> <div class=\"portal\" role=\"navigation\" id='p-wikibase-otherprojects' aria-labelledby='p-wikibase-otherprojects-label'>\n"
+ " <h3 id='p-wikibase-otherprojects-label'>В других других</h3>\n\n"
+ " </div> <div class=\"portal\" role=\"navigation\" id='p-lang' aria-labelledby='p-lang-label'>\n"
+ " <h3 id='p-lang-label'>Три три три</h3>\n\n"
+ " </div> \n";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}