use strict;
my $str = '<div class="portal" role="navigation" id=\'p-participation\' aria-labelledby=\'p-participation-label\'>
<h3 id=\'p-participation-label\'>Раз раз раз</h3>
</div> <div class="portal" role="navigation" id=\'p-tb\' aria-labelledby=\'p-tb-label\'>
<h3 id=\'p-tb-label\'>Инструменты</h3>
</div> <div class="portal" role="navigation" id=\'p-coll-print_export\' aria-labelledby=\'p-coll-print_export-label\'>
<h3 id=\'p-coll-print_export-label\'>Печать/экспорт</h3>
</div> <div class="portal" role="navigation" id=\'p-wikibase-otherprojects\' aria-labelledby=\'p-wikibase-otherprojects-label\'>
<h3 id=\'p-wikibase-otherprojects-label\'>В других других</h3>
</div> <div class="portal" role="navigation" id=\'p-lang\' aria-labelledby=\'p-lang-label\'>
<h3 id=\'p-lang-label\'>Три три три</h3>
</div>
';
my $regex = qr/<div\sclass="portal"(.*?)<\/div>/sp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}