package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)database_name.*table.*`)
var str = `database_name.table1
/database_name.table1
database_name.table_1
/folder1/folder2/greetings.csv
/folder1/folder2/greetings_1.csv
/folder1/greetings1.csv
/folder1/greetings1.txt
/folder2/folder3/bills3.csv
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}