import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "database_name.*table.*";
final String string = "database_name.table1\n"
+ "/database_name.table1\n"
+ "database_name.table_1\n"
+ "/folder1/folder2/greetings.csv\n"
+ "/folder1/folder2/greetings_1.csv\n"
+ "/folder1/greetings1.csv\n"
+ "/folder1/greetings1.txt\n"
+ "/folder2/folder3/bills3.csv\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}