use strict;
my $str = 'database_name.table1
/database_name.table1
database_name.table_1
/folder1/folder2/greetings.csv
/folder1/folder2/greetings_1.csv
/folder1/greetings1.csv
/folder1/greetings1.txt
/folder2/folder3/bills3.csv
';
my $regex = qr/database_name.*table.*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}