using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\$.*?\$(*SKIP)(*FAIL)|\\\w+(?=\s)";
string input = @"Example of \bad command. Example of \good\ command. And $x=\math + y$.
Example of \bad command. Example of \good\ command. And $x=\math + y$.
";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}