import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\$.*?\\$(*SKIP)(*FAIL)|\\\\\\w+(?=\\s)";
final String string = "Example of \\bad command. Example of \\good\\ command. And $x=\\math + y$.\n"
+ "Example of \\bad command. Example of \\good\\ command. And $x=\\math + y$.\n";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}