re = /\$.*?\$(*SKIP)(*FAIL)|\\\w+(?=\s)/
str = 'Example of \\bad command. Example of \\good\\ command. And $x=\\math + y$.
Example of \\bad command. Example of \\good\\ command. And $x=\\math + y$.
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end