#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(SELECT|UPDATE|((INSERT|DELETE)[ \t]+(INTO|FROM)))[ \t](.|[ \t])+[ \t]((FROM|SET|VALUES)[ \t])?"
Local $sString = "SELECT * FROM pizza" & @CRLF & _
"INSERT INTO Customers (CustomerName, ContactName, Address, City, PostalCode, Country)" & @CRLF & _
"VALUES ('Cardinal', 'Tom B. Erichsen', 'Skagen 21', 'Stavanger', '4006', 'Norway');" & @CRLF & _
"I like to INSERT pinapples INTO the VALUES" & @CRLF & _
"DELETE FROM TABLE WHERE" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")