import re
regex = re.compile(r"(SELECT|UPDATE|((INSERT|DELETE)[ \t]+(INTO|FROM)))[ \t](.|[ \t])+[ \t]((FROM|SET|VALUES)[ \t])?", flags=re.MULTILINE)
test_str = ("SELECT * FROM pizza\n"
"INSERT INTO Customers (CustomerName, ContactName, Address, City, PostalCode, Country)\n"
"VALUES ('Cardinal', 'Tom B. Erichsen', 'Skagen 21', 'Stavanger', '4006', 'Norway');\n"
"I like to INSERT pinapples INTO the VALUES\n"
"DELETE FROM TABLE WHERE\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")