// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(SELECT|UPDATE|((INSERT|DELETE)[ \t]+(INTO|FROM)))[ \t](.|[ \t])+[ \t]((FROM|SET|VALUES)[ \t])?").unwrap();
let string = "SELECT * FROM pizza
INSERT INTO Customers (CustomerName, ContactName, Address, City, PostalCode, Country)
VALUES ('Cardinal', 'Tom B. Erichsen', 'Skagen 21', 'Stavanger', '4006', 'Norway');
I like to INSERT pinapples INTO the VALUES
DELETE FROM TABLE WHERE
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}