package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im).* ([^a-z]+)$`)
var str = `Job number 45752 Subtotal price $937.50
Job number 7852 Subtotal amount $637.50
Job number 42 Subtotal test $427.50
Job number 47592 Subtotal sample $976.50 `
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}