const regex = /.* ([^a-z]+)$/igm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.* ([^a-z]+)$', 'igm')
const str = `Job number 45752 Subtotal price \$937.50
Job number 7852 Subtotal amount \$637.50
Job number 42 Subtotal test \$427.50
Job number 47592 Subtotal sample \$976.50 `;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);