// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?im).* ([^a-z]+)$").unwrap();
let string = "Job number 45752 Subtotal price $937.50
Job number 7852 Subtotal amount $637.50
Job number 42 Subtotal test $427.50
Job number 47592 Subtotal sample $976.50 ";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}