using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*(-[dn] .*)$";
string input = @"hello world blah -d blah vlaah -n blah vlahh
hello world blah -n blah vlahh -d blah vlaah
hello world blah -d blaaah";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}