// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^.*(-[dn] .*)$").unwrap();
let string = "hello world blah -d blah vlaah -n blah vlahh
hello world blah -n blah vlahh -d blah vlaah
hello world blah -d blaaah";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}