package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.*(-[dn] .*)$`)
var str = `hello world blah -d blah vlaah -n blah vlahh
hello world blah -n blah vlahh -d blah vlaah
hello world blah -d blaaah`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}