package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^;[A-Za-z ]+(?:;[0-9]+){2}(?:;event[1-9][0-9]?=[0-9]+(?:\.[0-9]+)?)?(?:;eVar[1-9][0-9]?=[A-Za-z ]+)?$`)
var str = `;XYZ;2;200;event18=2.5;eVar12=Sale
;XYZ;2;200;event18=2.5
;XYZ;2;200;eVar12=Sale
;XYZ;2;200;event1=25;eVar12=Sale
;XYZ;2;200;event18=2.5
;XYZ;2;200;eVar2=Sale of the day`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}