$re = '~^;[A-Za-z ]+(?:;[0-9]+){2}(?:;event[1-9][0-9]?=[0-9]+(?:\.[0-9]+)?)?(?:;eVar[1-9][0-9]?=[A-Za-z ]+)?$~m';
$str = ';XYZ;2;200;event18=2.5;eVar12=Sale
;XYZ;2;200;event18=2.5
;XYZ;2;200;eVar12=Sale
;XYZ;2;200;event1=25;eVar12=Sale
;XYZ;2;200;event18=2.5
;XYZ;2;200;eVar2=Sale of the day';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);