// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^;[A-Za-z ]+(?:;[0-9]+){2}(?:;event[1-9][0-9]?=[0-9]+(?:\.[0-9]+)?)?(?:;eVar[1-9][0-9]?=[A-Za-z ]+)?$").unwrap();
let string = ";XYZ;2;200;event18=2.5;eVar12=Sale
;XYZ;2;200;event18=2.5
;XYZ;2;200;eVar12=Sale
;XYZ;2;200;event1=25;eVar12=Sale
;XYZ;2;200;event18=2.5
;XYZ;2;200;eVar2=Sale of the day";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}