using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(jest)+(?!.*brak.*)";
string input = @"tu jest dom, a tu barak
to jest a tu brak
to jest coś";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}