$re = '/(jest)+(?!.*brak.*)/';
$str = 'tu jest dom, a tu barak
to jest a tu brak
to jest coś';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);