re = /(jest)+(?!.*brak.*)/
str = 'tu jest dom, a tu barak
to jest a tu brak
to jest coś'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end