#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)([\w.]+@[\w.]+)|(?:(?:\b|[,/]\s*)(?:whatsapp|viber|wechat))+\b\s*[::]?\s*([()+\d -]+\d)|\bline(?:\sid)?\s*(?:[::]\s*)?@?(\w+)|((?:\+\d+[ -]?)?(?:\(\d+\)[ -]?)?\d[\d -]{5,}\d)"
Local $sString = "??5-yr online store ? Real pictures?? ?Mirror Quality ??1:1 ?Whatsapp/Viber +861776345378 ?spikydudewonderland@gmail.com ✈️✈️Worldwide Shipping" & @CRLF & _
"" & @CRLF & _
"Девочки это наша новая страничка.Только копии Lux, искателям дешевых подделок не беспокоить. По всем вопросам viber,whatsapp +79128743333 Лианна" & @CRLF & _
"" & @CRLF & _
"Recruitment Agents????The most powerful manufacturers,we have thebest quality.?Wechat:13255996580??Whatsapp:+8618820784535" & @CRLF & _
"" & @CRLF & _
"? เข้าช้อปทุกวันจ้า? ซื้อกับวี้ได้ของแท้แน่นอนค่า? แบรนด์อื่นสอบถามได้ค่า? ดรีวิว@reviewkayasisshopp? LINE ID : @kux1427k (มี @ ด้วยจ้า)" & @CRLF & _
"" & @CRLF & _
"Menyediakan Kacamata Termurah dengan Kualitas Super" & @CRLF & _
"from: Surabaya" & @CRLF & _
"Tanya / order : " & @CRLF & _
"pin bb : 59f72347" & @CRLF & _
"WA/SMS/Call : 082231506095" & @CRLF & _
"Line : qurotinayunina" & @CRLF & _
"" & @CRLF & _
"?Brandname Hiend สั่งเมื่อพร้อมโอน?CFห้ามCC?ship world wide ?LINE:@candy_hiend(มี@) candy_hiend@hotmail.com" & @CRLF & _
"" & @CRLF & _
"0532 397 49 40" & @CRLF & _
"1-877-958-5211" & @CRLF & _
"(38)99937-7007" & @CRLF & _
"+12345678" & @CRLF & _
"+1234567"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")